Our full technical support staff does not monitor this forum. If you need assistance from a member of our staff, please submit your question from the Ask a Question page.


Log in or register to post/reply in the forum.

CR300-CELLxxx Monitoring Cellular Network


ariklee Nov 30, 2018 12:11 PM

Hi,

I've got a CR300-CELL205 in the field on the Konect service. I lost comm for about 3 weeks, it was restored recently. During the outtage, I logged into Konect a few times to check my Pakbus Router Status, and it showed the node as being "Not Connected".

Now I am able to connect. The hourly data shows that the battery remained strong over the course of the lost comm. The status table shows nothing strange (i.e., no watchdogs, no errors, etc). However, the signal strength is -95 and the quality is -6. The "Cellular Network Status" box indicates that I am on a 3G network. Couple questions:

1. I'm going to update my program to read Settings.CellRSSI and store it in a data table. There are a bunch of other Cell variables that I can read and store to troubleshoot the system (i.e., CellECIO, CellINFO, CellState, CellStatus) -- which would you read and store to troubleshoot?

2. Because the 3G strength seems low (-95), and I know the device is on the edge of possible comm with 4G, is it possible that the cellular gateway is periodically picking up enough 4G to switch over to 4G, but then does not have enough signal strength to actually communicate?

Thanks,

Eric


ariklee Dec 17, 2018 08:34 AM

Bumping this up to the top. I found out that my client(s) reset the dataloggers (cycled power), and connection through the CELL205 was reestablished (nodes were "not connected" on Konect, then reconnected after power was cycled).

The same thing happened to me in two separate projects, both using CR300-CELL205. Advice on monitoring the cell network parameters? This is beginning to seem like an OS bug and not communication issue, because cycling power reestablishes comm.

Is this the 50-day lost comm OS bug reappearing?


ariklee Dec 17, 2018 02:09 PM

FYI I am using OS 7.05.


Travis Barney Dec 18, 2018 09:23 AM

The CR300-CELL2xx keeps a log of errors/issues for the cellular module.  This is helpful when diagnosing modem issues.  You can capture the log by using the following terminal command:

CR300>SHOW CELL LOG

This is the key for the cellular log:

Boot = Cellular modem boot failure
SIM = SIM card failure
PWR = Power failure
NET D = Network denied
Baud = Baud rate failure
PPP = PPP failure
K-Alive = Keep alive reset
Dial = Dial failure
Cmd to PPP = Command mode to PPP mode failure
PPP to Cmd = PPP mode to command mode failure
PPP drop = PPP dropped
PPP neg = PPP negotiation fail
AT Cmd = AT command failure
Cmd no rsp = AT command fail. No response
NO CAR = NO CARRIER received from modem. PPP session dropped by carrier.
NO CAR rst = Modem was reset due to NO CARRIER errors.
ModemReset = Modem reset on it's own.
PDPactFail = PDP activation failure
PPP IP add = PPP IP address fail

There have also been several updates/bug fixes in OS 8.00 that may fix the issue.


GaryTRoberts Dec 18, 2018 09:49 AM

We found a dialing bug in the CR300 OS that could cause the modem / logger to get into a dialing loop. This issue is resolved in OS 08.00 which should be posted on the downloads website today.


ariklee Dec 18, 2018 02:00 PM

Thanks!

If I send the new OS remotely, I suspect that I will lose the cell configuration (IP address, DNS, etc)... and thus the ability to communicate with it. Is there any way I can do this remotely and have a program on it run that sets the necessary comm parameters?

Eric


ariklee Jan 3, 2019 02:37 PM

To close this out.... I was succesfuly able to remotely send the new OS to the CR300-CELL205 going through the "connect" screen, then "file control" screen. All settings remained and communcation was restored after the OS was loaded. It took me several tries to send it (communication was lost each time, but the old OS and program remained in place). Finally, I reduced the maximum packet size to 300, and increased the communication delay in the pakbus router to 2s and sent the OS successfully to 2 different devices.


jtbrock Jan 4, 2019 04:14 PM

On my CR300-CELL205 I read Signal Strength with a line in the program

CellRSSI = status.CellRSSI

not Settings.CellRSSI 

as was indicated in the initial post of Nov 30 2018.  

Log in or register to post/reply in the forum.